A vast majority of Aclara hosted systems are recovered, so we consider this incident to be resolved. If you and any of your users are still encountering missing menu options, or missing data within AclaraONE, please open a support case via AclaraConnect for assistance.
Thank you in advance for your patience and understanding.
Many Aclara hosted systems appear to be recovering although additional time will be needed to ensure full recovery. Therefore, we are continuing to monitor as systems continue to improve.
Posted Nov 18, 2025 - 11:08 EST
Identified
Cloudflare has identified the issue and is actively working to apply a fix, Aclara will continue to monitor as changes occur
Posted Nov 18, 2025 - 09:57 EST
Investigating
Aclara is experiencing a technical issue with our AclaraONE hosted environment. Details on the incident are below.
Global outages and delays from Cloudflare are causing Aclara hosting environment user access issues. The issue has been identified and a resolution is under way via Cloudflare.
Event Priority: High Event Date and Time approximate occurrence: November 18, 2025 06:00 AM ET Next Update: November 18, 2025 10:00 AM ET Estimated Date/Time of Resolution: TBD
Thank you in advance for your patience and understanding. Please contact us at any of the methods below for more information.