AMC Portal Not Accessible

Incident Report for AclaraHosting

Resolved

This incident has been resolved.
Posted Mar 07, 2026 - 14:57 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 07, 2026 - 14:14 EST

Investigating

Aclara is experiencing a technical issue with our Aclara Metrum Cellular (AMC) environment. Details on the incident are below.

Users cannot log into the portal resulting in the following error: 504 Gateway Time-out.

We are working to resolve the connectivity issue.

Event Priority:
Standard
Event Date and Time:
March 7, 2026 12:51 PM ET
Next Update:
July 12, 2026 02:30 PM ET
Estimated Date/Time of Resolution:
July 12, 2026 03:00 PM ET



Thank you in advance for your patience and understanding. Please contact us at any of the methods below for more information.

Sincerely,
Aclara Support

AclaraConnect Portal Login: https://aclara.com/
1.800.892.9008
Please direct all emails to AclaraSupport@hubbell.com
Posted Mar 07, 2026 - 13:54 EST
This incident affected: Aclara Metrum Cellular Portal.